Browsers and devices support

We breakdown browser and device support for CloudTables into two separate sections:

  • App - the configuration UI (anything with the cloudtables.com domain)
  • Edge - the tables and forms embedded into your own pages (uses the cloudtables.io domain).

App

It is expected that system adminstrators will generally be using modern browsers, with a tablet or larger sized screen. As such we support the following browsers:

  • Desktop
    • Chrome - Current and previous releases
    • Firefox - Current, previous and current ESR releases
    • Safari - Current and previous releases
    • Edge - Current and previous releases
  • Tablet
    • iOS - Safari: 12+
    • Android - Chrome: Current and previous releases

The devices supported are:

  • Desktop / laptops with 1080p or larger screens
  • iPad which can run iOS 12 or newer
  • Android tablets running Android 8 or newer
  • Chrome OS Current and previous releases

See updatemybrowser.org for details of the current versions of the major browsers.

Edge

While it is expected that computers accessing the main CloudTables configuration UI will be relatively modern and powerful, it is likely you have less control over the computers and browsers that your end users will be using to access pages which have CloudTables embedded into them. As such, we provide support for a wider range of browsers and devices for the embedded content:

  • Desktop
    • Chrome - Current and previous releases
    • Firefox - Current, previous and current ESR releases
    • Safari - Current and previous releases
    • Edge - Current and previous releases
    • Internet Explorer - 11
    • Opera - Current release
  • Tablet and mobile
    • iOS - Safari: 11+
    • Android - Chrome: Current and previous releases

The devices supported are:

  • Smart phones:
    • iPhone running iOS 11 or newer
    • Android phones running Android 8 (Oreo) or newer
  • Tablets
    • iPad running iOS 11 or newer
    • Android tablets running Android 8 (Oreo) or newer
    • Chrome OS devices - Current and previous releases
  • Desktop / laptops
    • Windows - 7+
    • macOS - 10.13+
    • Linux - any which supports the above browsers